I've Had It With Mk4's !!!!

20 Studio, 50+, 50PA, 50R, L100, B100, L120, L120PA, L120R, 120 SLAVE, B120, B150, L150, L200, B200, Concord, and SMF

I've Had It With Mk4's !!!!

Postby gldtp99 on Tue Sep 21, 2004 6:02 am

i'm at the point of complete frustration with SC 120 mk4 preamps----- i've re-furbed/shotgunned several and i've gotten very good results (great sound, tone, power)---but only temporarily---one has turned into an oscillating nightmare--- another that i'd been using for bass/guitar with good results for months has developed noise problems--tubes that are fine in other amps are very microphonic in this one suddenly (getting screwy pin voltages that vary with no rhyme/reason)---- i think that the cloth-covered longitudal wire network is cross-feeding at will---i could re-do all these wires but instead i believe i've been converted to the "Pre-Amp Conversion" method of dealing with mk4 pre's--- maybe this is why some techs won't work on mk4's---i've done some "Fender-y" preamp conversions on several 10-to-60 watt amps with terrific results (some local bands are using them constantly)--- and will do a couple more for practice (one "Marshall-y") before i start on one of the 120's----- i've found by working with other amps that a rich, powerful sound can be had without the extra noise/complexity of mk4's---- i really do like the sound of 120 mk4's when they work right--- my 120 Tour Series is still working rock-solid---- but the active/ladder circut is something that is beyond my abilities to fix more than tempoarily.................gldtp99
User avatar
gldtp99
Baron
 
Posts: 2360
Joined: Sun Mar 23, 2003 8:01 am
Location: Texas

Re: I've Had It With Mk4's !!!!

Postby drewl on Tue Sep 21, 2004 10:49 am

hmmm I guess I'm lucky mine's pretty quiet, after replacing filter caps.
i can get to sound great, but it takes some tweakin with the active EQ< so I'm sure someday I'll rip it all out and build a hiwatt preamp into it!
User avatar
drewl
Prince
 
Posts: 4602
Joined: Mon Jun 18, 2001 7:01 am
Location: Norristown state hospital

Re: I've Had It With Mk4's !!!!

Postby Capt.Strat on Sun Sep 26, 2004 10:16 pm

I just started re-doing my B-120 with a Hiwatt DR-103 pre yesterday. It's a pretty big job so it'll take a while, but I'll let you know how it works out.
User avatar
Capt.Strat
Knight
 
Posts: 1629
Joined: Thu Jun 27, 2002 7:01 am
Location: Massachusetts

Re: I've Had It With Mk4's !!!!

Postby gldtp99 on Mon Sep 27, 2004 9:17 am

i've had a DR103 and played other DR103's and although many seem to consider them "holy grail" they are not my favorites---- so a Hiwatt pre-amp job in a SC is not something i'll be doing--- i've got some ideas and i'll try some of them out on smaller, cheaper PA amp conversions first---i got a report back on a Knight 33 watt PA conversion i sold a while back (one "fender" channel and one "atomic 16--soldano" channel)--- the current owner has been blowing away other "real" ($$$) amps at blues jams and wants to buy more amps like this---- maybe something along these lines for the SC 120's........but it seems wrong to not use all those pre-amp tube sockets ---- more pre tubes=more gain (for lead channel)---- i'm not sure yet-- many possibilities..........gldtp99
User avatar
gldtp99
Baron
 
Posts: 2360
Joined: Sun Mar 23, 2003 8:01 am
Location: Texas

Re: I've Had It With Mk4's !!!!

Postby EF86-FAN on Mon Sep 27, 2004 5:14 pm

I did a very sucessful conversion on an L120 with the L100 preamp - the choke mod was a big improvement too.

I think I'd probably just do a DR103 preamp next time for a vintage vibe or a total rock beast SLO100 type hotrod depending on what type of band I'm in at the time.

:cool:
EF86-FAN
Certified
 
Posts: 173
Joined: Mon Mar 31, 2003 8:01 am
Location: Newcastle

Re: I've Had It With Mk4's !!!!

Postby djh8 on Mon Sep 27, 2004 5:56 pm

I have also converted an L120 to Hiwatt preamp (early 80s two input 'OL' preamp) which has Hiwatt tone controls and master volume. I have used the slave jack sockets for extra pots. The schematic was found at mhuss.com/hiwatt - a great site for Hiwatt amps - I am very happy with the conversion.
In addition, I have added a reverb using am SJB Ant circuit, with ECF 82 (6U8A) pentode/triode valve using an Accutronics 8FB2C1B reverb. I am currently drawing the revised schematic in Visio, if any one wants a copy when finished, I will be happy to oblige.

Dave Hunter
djh8
Peasant
 
Posts: 30
Joined: Sun Jun 20, 2004 7:01 am
Location: Nottingham, UK

Re: I've Had It With Mk4's !!!!

Postby 1953Vintage on Mon Sep 27, 2004 6:01 pm

DaveH...

I'd love to post a copy of your modification/schematic at the Sound City web site. I could link to it if you're planning to post it somewhere or you could send me an electronic copy as a PDF file.

Thanks and best regards!
Michael
Visit the Sound City Site!
User avatar
1953Vintage
Baron
 
Posts: 2591
Joined: Mon Sep 16, 2002 7:01 am
Location: Albuquerque

Re: I've Had It With Mk4's !!!!

Postby djh8 on Mon Sep 27, 2004 8:12 pm

Michael,

Would be more than happy to, can't believe my old battered SC would make it onto your great web site!

Cheers,

DaveH
djh8
Peasant
 
Posts: 30
Joined: Sun Jun 20, 2004 7:01 am
Location: Nottingham, UK

Re: I've Had It With Mk4's !!!!

Postby 1953Vintage on Tue Sep 28, 2004 1:38 am

:D
The only photos of SC stuff I haven't published have been blurry. The condition of an amp means nothing to me.... I can't speak for others, but to me... it doesn't matter. And the schematic would be a great addition!

Best regards!
Michael
Visit the Sound City Site!
User avatar
1953Vintage
Baron
 
Posts: 2591
Joined: Mon Sep 16, 2002 7:01 am
Location: Albuquerque

Re: I've Had It With Mk4's !!!!

Postby djh8 on Tue Sep 28, 2004 7:41 pm

Michael,
Actually my amp is pretty good condition, but I've had to add labels (black with silver background) on the front panel for master volume and reverb, plus places where the original markings have worn off.
Anyhow, when I've finished the schematic, I will send it to you with a few photos of the amp (not Blurred, I promise!) and you can decide if you think it should go on your site.

Cheers,

Dave Hunter
djh8
Peasant
 
Posts: 30
Joined: Sun Jun 20, 2004 7:01 am
Location: Nottingham, UK

Re: I've Had It With Mk4's !!!!

Postby 1953Vintage on Sun Oct 10, 2004 5:41 pm

Gldtp99...

i'm at the point of complete frustration with SC 120 mk4 preamps
I know Arlington, TX is around 500 miles away from Albuquerque, but should you ever find yourself here or simply driving through (on I-40), please plan on contacting me and stopping by to hear my heavily modified 120 (Hoffman Amps' "Plexi 100" preamp mod and a couple of other things as well). It just sounds perfect to my ears. Bring a guitar, and oh yeah... the first round is on me.

Best regards!
Michael
Visit the Sound City Site!
User avatar
1953Vintage
Baron
 
Posts: 2591
Joined: Mon Sep 16, 2002 7:01 am
Location: Albuquerque

Re: I've Had It With Mk4's !!!!

Postby gldtp99 on Mon Oct 11, 2004 8:34 am

Michael---- Thanx for the invite, i'll take you up on that----i just finished a JCM 800 (2204)preamp conversion on a 50 watt Rauland PA head and i'll do a Plexi pre job on a Bogen 50 watt PA head next--- i'm doing these to practice before i do one of my SC 120's--- i have a general plan to do a BF Fender clean channel and a JCM 800 or Plexi lead channel job on a SC 120--- i bet yours sounds fantastic--- i'd love to hear it!!!--- i'll bring my 120 Tour Series--- i've got some tweaking ideas for the "Dirty" channel on that one.........gldtp99
User avatar
gldtp99
Baron
 
Posts: 2360
Joined: Sun Mar 23, 2003 8:01 am
Location: Texas

Re: I've Had It With Mk4's !!!!

Postby 1953Vintage on Mon Oct 11, 2004 1:07 pm

Seriously... if you could pull it off, that would be great. I'd even be willing to have you take the head with you to draw up a schematic (if you're able to do this, of course) for other frustrated Mark 4 owners who might be interested in the mods. You could then just ship it back to me, and I'd be happy to spring for FedEx shipping.

Think about it.

Best regards!
Michael
Visit the Sound City Site!
User avatar
1953Vintage
Baron
 
Posts: 2591
Joined: Mon Sep 16, 2002 7:01 am
Location: Albuquerque


Return to Sound City

Who is online

Users browsing this forum: No registered users and 1 guest